<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://dallasvoice.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://dallasvoice.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://dallasvoice.com';var et_post_id='1000316067';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Om naturel - Dallas Voice</title>

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://dallasvoice.com/om-naturel/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Om naturel - Dallas Voice" />
<meta property="og:description" content="Roberto Alvarez, left, practices yoga alongside students Tim Lewis, Robert Elorduy and Demetres Hunter. (Photography by Arnold Wayne Jones) Leave your anxiety, your ego and your clothes at the door for Radical Yoga RICH LOPEZ  | Contributing Writer richlopezwrites@gmail.com For some queer men, it might be a fantasy to strip off all their clothes and &hellip;" />
<meta property="og:url" content="https://dallasvoice.com/om-naturel/" />
<meta property="og:site_name" content="Dallas Voice" />
<meta property="article:tag" content="lgbt" />
<meta property="article:section" content="Featured" />
<meta property="article:published_time" content="2020-01-24T13:50:09+00:00" />
<meta property="article:modified_time" content="2020-01-23T17:31:44+00:00" />
<meta property="og:updated_time" content="2020-01-23T17:31:44+00:00" />
<meta property="og:image" content="https://dallasvoice.com/wp-content/uploads/2020/01/Om-nature.jpg" />
<meta property="og:image:secure_url" content="https://dallasvoice.com/wp-content/uploads/2020/01/Om-nature.jpg" />
<meta property="og:image:width" content="948" />
<meta property="og:image:height" content="557" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Roberto Alvarez, left, practices yoga alongside students Tim Lewis, Robert Elorduy and Demetres Hunter. (Photography by Arnold Wayne Jones) Leave your anxiety, your ego and your clothes at the door for Radical Yoga RICH LOPEZ  | Contributing Writer richlopezwrites@gmail.com For some queer men, it might be a fantasy to strip off all their clothes and [&hellip;]" />
<meta name="twitter:title" content="Om naturel - Dallas Voice" />
<meta name="twitter:image" content="https://dallasvoice.com/wp-content/uploads/2020/01/Om-nature.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://dallasvoice.com/#website","url":"https://dallasvoice.com/","name":"Dallas Voice","description":"The Premier Media Source for LGBT North Texas","potentialAction":{"@type":"SearchAction","target":"https://dallasvoice.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://dallasvoice.com/om-naturel/#primaryimage","url":"https://dallasvoice.com/wp-content/uploads/2020/01/Om-nature.jpg","width":948,"height":557},{"@type":"WebPage","@id":"https://dallasvoice.com/om-naturel/#webpage","url":"https://dallasvoice.com/om-naturel/","inLanguage":"en-US","name":"Om naturel - Dallas Voice","isPartOf":{"@id":"https://dallasvoice.com/#website"},"primaryImageOfPage":{"@id":"https://dallasvoice.com/om-naturel/#primaryimage"},"datePublished":"2020-01-24T13:50:09+00:00","dateModified":"2020-01-23T17:31:44+00:00","author":{"@id":"https://dallasvoice.com/#/schema/person/e8eb74f722169a5c6690b5e6091e4316"}},{"@type":["Person"],"@id":"https://dallasvoice.com/#/schema/person/e8eb74f722169a5c6690b5e6091e4316","name":"Kevin","image":{"@type":"ImageObject","@id":"https://dallasvoice.com/#authorlogo","url":"https://secure.gravatar.com/avatar/4b98a7d97ac281ba11418ed5f2d288f5?s=96&d=mm&r=g","caption":"Kevin"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Dallas Voice &raquo; Feed" href="https://dallasvoice.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Dallas Voice &raquo; Comments Feed" href="https://dallasvoice.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Dallas Voice &raquo; Om naturel Comments Feed" href="https://dallasvoice.com/om-naturel/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dallasvoice.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<meta content="Dallas Voice v.1.0.0" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://dallasvoice.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://dallasvoice.com/wp-content/themes/Extra/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css' href='https://dallasvoice.com/wp-content/themes/dallasvoice/style.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='et-builder-googlefonts-cached-css' href='https://fonts.googleapis.com/css?family=Lato%3A100%2C100italic%2C300%2C300italic%2Cregular%2Citalic%2C700%2C700italic%2C900%2C900italic&#038;ver=5.3.2#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://dallasvoice.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript' src='https://dallasvoice.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://dallasvoice.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_core_api_spam_recaptcha = {"site_key":"","page_action":{"action":"omnaturel"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dallasvoice.com/wp-content/themes/Extra/core/admin/js/recaptcha.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://dallasvoice.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dallasvoice.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dallasvoice.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://dallasvoice.com/?p=1000316067' />
<link rel="alternate" type="application/json+oembed" href="https://dallasvoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdallasvoice.com%2Fom-naturel%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dallasvoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdallasvoice.com%2Fom-naturel%2F&#038;format=xml" />


<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-2 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:600px; }
	.g-3 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:90px; }
	.g-4 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-5 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:600px; }
	.g-6 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-7 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:90px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>

<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-60733171-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments)};
  gtag('js', new Date());

  gtag('config', 'UA-60733171-1');
</script>
<script type="text/javascript">
jQuery(document).ready(function($) {
$(" .carousel-item").click(function() {
window.location = $(this).find(" .post-content h3.entry-title a").attr("href"); 

});
});
</script>

<script type="text/javascript">
jQuery(document).ready(function(){
jQuery(".page-id-1000257391 .et_pb_posts a").attr('target', '_blank');
});
</script><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://dallasvoice.com/wp-content/et-cache/global/et-extra-customizer-global-15798223029546.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><link rel="stylesheet" id="et-core-unified-1000316067-cached-inline-styles" href="https://dallasvoice.com/wp-content/et-cache/1000316067/et-core-unified-1000316067-15798740537807.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-1000316067 single-format-standard et_bloom et_extra et_non_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="">
<ul id="et-secondary-menu" class="nav"><li id="menu-item-256438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256438"><a href="/advertising">Advertise With Us</a></li>
<li id="menu-item-256439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256439"><a href="/marketplace">Marketplace</a>
<ul class="sub-menu">
<li id="menu-item-256440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256440"><a href="/marketplace">View This Week&#8217;s PDF</a></li>
<li id="menu-item-256441" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256441"><a href="https://dallasvoice.com/wp-content/uploads/2017/10/MarketPlace-Rate-Card.pdf">Marketplace Media Kit</a></li>
</ul>
</li>
<li id="menu-item-256442" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256442"><a href="/outnorthtexas">OUT North Texas</a>
<ul class="sub-menu">
<li id="menu-item-256443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256443"><a href="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/01/OUT-NT-2019.pdf">Read the Magazine</a></li>
<li id="menu-item-256444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256444"><a href="https://directory.outntx.com/">Business Directory</a></li>
<li id="menu-item-256445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256445"><a href="https://dallasvoice.com/outnorthtexas/media-kit/">OUT Media Kit</a></li>
</ul>
</li>
<li id="menu-item-256446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256446"><a href="/media-kit">Digital Services</a></li>
<li id="menu-item-256447" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256447"><a href="/contact">Contact Us</a></li>
</ul> </div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://www.facebook.com/DallasVoiceLGBT/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/DallasVoice" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://instagram.com/dallas_voice" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
 <li class="et-extra-social-icon youtube">
<a href="https://www.youtube.com/channel/UCzLKquBnVnmwE8LBYSQTK3w" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-youtube"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="https://dallasvoice.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="https://dallasvoice.com/" data-fixed-height="51">
<img src="https://dallasvoice.com/wp-content/uploads/2017/09/DallasVoice_Website_Logo_cyan.png" alt="Dallas Voice" id="logo" />
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-256449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256449"><a href="/category/news">News</a>
<ul class="sub-menu">
<li id="menu-item-256450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256450"><a href="/category/news/texas">Local News</a></li>
<li id="menu-item-256451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256451"><a href="/category/news/national">National News</a></li>
<li id="menu-item-256452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256452"><a href="/category/featured">Featured</a>
<ul class="sub-menu">
<li id="menu-item-256453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256453"><a href="/lambda">Lambda Weekly</a></li>
<li id="menu-item-1000292637" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1000292637"><a href="https://dallasvoice.com/category/editorial-cartoon/">Editorial Cartoon</a></li>
<li id="menu-item-1000292638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1000292638"><a href="https://dallasvoice.com/category/crossword/">Crossword Puzzle</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-256454" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-256454"><a href="https://dallasvoice.com/category/lifestyle/">Life+Style</a>
<ul class="sub-menu">
<li id="menu-item-256455" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256455"><a href="https://dallasvoice.com/category/profile/">Profile</a></li>
<li id="menu-item-256456" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256456"><a href="https://dallasvoice.com/category/stage/">Stage</a></li>
<li id="menu-item-256457" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256457"><a href="https://dallasvoice.com/category/screen/">Screen</a></li>
<li id="menu-item-256458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256458"><a href="https://dallasvoice.com/category/dining/">Dining</a></li>
<li id="menu-item-256466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256466"><a href="https://dallasvoice.com/category/travel/">Travel</a></li>
<li id="menu-item-256467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256467"><a href="https://dallasvoice.com/category/community/">Community</a></li>
<li id="menu-item-256468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256468"><a href="https://dallasvoice.com/category/tube/">Tube</a></li>
<li id="menu-item-256469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256469"><a href="https://dallasvoice.com/category/concert-lifestyle/">Concert</a></li>
<li id="menu-item-256470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256470"><a href="https://dallasvoice.com/category/music/">Music</a></li>
<li id="menu-item-256471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256471"><a href="https://dallasvoice.com/category/books/">Books</a></li>
<li id="menu-item-256472" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256472"><a href="https://dallasvoice.com/category/fashion/">Fashion</a></li>
<li id="menu-item-256473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256473"><a href="https://dallasvoice.com/category/auto/">Auto</a></li>
<li id="menu-item-256474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256474"><a href="https://dallasvoice.com/category/scoop-lifestyle/">Scoop</a></li>
<li id="menu-item-256475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256475"><a href="https://dallasvoice.com/category/sports/">Sports</a></li>
<li id="menu-item-256476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256476"><a href="https://dallasvoice.com/category/sketches/">Sketches</a></li>
<li id="menu-item-256477" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256477"><a href="https://dallasvoice.com/category/pride/">Pride</a></li>
<li id="menu-item-256478" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256478"><a href="https://dallasvoice.com/category/advice/">Advice</a></li>
<li id="menu-item-256479" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256479"><a href="https://dallasvoice.com/category/plan-your-week/best-bets/">Best Bets</a></li>
</ul>
</li>
<li id="menu-item-256480" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256480"><a href="/category/instantea">InstanTEA</a>
<ul class="sub-menu">
<li id="menu-item-256481" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256481"><a href="https://dallasvoice.com/category/instantea/news-instant-tea/">InstanTEA News</a></li>
<li id="menu-item-256482" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256482"><a href="https://dallasvoice.com/category/instantea/lifestyle-instant-tea/">InstanTEA Life+Style</a></li>
<li id="menu-item-256483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256483"><a href="https://dallasvoice.com/category/instantea/community-voices-instant-tea/">CommUNITY Voices</a></li>
</ul>
</li>
<li id="menu-item-256484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256484"><a href="/category/special-editions">Special Sections</a></li>
<li id="menu-item-256485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256485"><a href="/plan-your-week">Plan Your Week</a></li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<article id="post-1000316067" class="module single-post-module post-1000316067 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-fitness category-lifestyle tag-lgbt et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Om naturel</h1>
<div class="post-meta vcard">
<p><span class="updated">Jan 24, 2020</span> | <a class="comments-link" href="https://dallasvoice.com/om-naturel/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://dallasvoice.com/wp-content/uploads/2020/01/Om-nature.jpg" alt="Om naturel" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p style="text-align: center;"><em>Roberto Alvarez, left, practices yoga alongside students Tim Lewis, Robert Elorduy and Demetres Hunter. (Photography by Arnold Wayne Jones)</em></p>
<h4>Leave your anxiety, your ego and your clothes at the door for Radical Yoga</h4>
<p><strong>RICH LOPEZ  |</strong> Contributing Writer<br />
<a href="/cdn-cgi/l/email-protection#ed9f848e8581829d88979a9f8499889ead8a808c8481c38e8280"><span class="__cf_email__" data-cfemail="5d2f343e3531322d38272a2f3429382e1d3a303c3431733e3230">[email&#160;protected]</span></a></p>
<p>For some queer men, it might be a fantasy to strip off all their clothes and writhe around with a bunch of other men. At Radical Yoga, that’s just a weekly thing.</p>
<p>But get your mind out of the gutter. It’s not like that.</p>
<p>Roberto Alvarez Jr.’s studio, inside the Vigor Massage space in East Dallas, is a place where those who are comfortable out of clothes can get their stretch on. But he also wants to provide a safe space for those with some trepidation and curiosity. Ultimately, everyone has his own reasons.</p>
<p>“There are a few things that lead people here,” Alvarez says. “They are either trying to recover from something or do something new. Some try it to be adventurous or just meet new people. But there is space for everybody.”</p>
<p>Alvarez, 29, started his classes in 2017 under the studio’s first moniker Naked Yoga Dallas. He’s revamped his studio to Radical Yoga with its first class, held just last week. Plus, the name seemed a better fit.</p>
<p>“Being naked is a form of being radical. It’s more than just taking off your clothes; it’s the symbolism in layers we have on ourselves,” he explains.</p>
<p>OK, but why yoga in the nude in the first place? The reason goes back to Alvarez’s college days.</p>
<p><img class="alignleft size-full wp-image-1000316068" src="https://dallasvoice.com/wp-content/uploads/2020/01/Yoga-2.jpg" alt="" width="500" height="333" srcset="https://dallasvoice.com/wp-content/uploads/2020/01/Yoga-2.jpg 500w, https://dallasvoice.com/wp-content/uploads/2020/01/Yoga-2-300x200.jpg 300w" sizes="(max-width: 500px) 100vw, 500px" />Yoga was part of Alvarez’s curriculum while studying dance in college. His interest grew when he pursued his masters at Texas Woman’s University, which also came in handy for another reason.</p>
<p>“Grad school was stressful! I was crying most of the time, so yoga kept me centered,” he says. “But that helped me learn that yoga was not just for the body but also the mind.</p>
<p>And then I did my first naked yoga in Austin where I saw men of all different ages and sizes forming community.”</p>
<p>The experience ended up being a profound one for Alvarez. He explains that he learned much about himself in many ways including understanding his own sexuality. Being naked, for him, stripped away more than just clothes, and he wanted others to know the same experience.</p>
<p>“So sure, clothes may get in the way, especially when they get sweaty, but when we just wear ourselves — especially as gay or queer men — to confront our bodies is a big thing.”</p>
<p>Gay culture is bombarded by images of ideal physiques, but gay men are also shamed about their bodies by society, religion and family, according to Alvarez. He sees the act of just removing clothes in this setting as healing.</p>
<p>“Firstly, the world doesn’t end,” he says. “Men will say they can’t do it. I get that. Whatever trauma tells them that, I reassure them that we’re all just doing our best, and that we’re all in this together.”</p>
<p>But there is one important question that just can’t be ignored, because the reality simply is that a boner might just join in on the yoga session. It’s a question Alvarez confronts so often that he’s put it on his website.</p>
<p>What happens if I get aroused?</p>
<p>Nothing. It might be your body’s natural response in this space — and that’s nothing to be ashamed of.</p>
<p>If anything, he flips the script on that whole situation.</p>
<p>“It’s a response from sensations in the body, and maybe on some level a projection, and that’s OK. I think we are afraid of who we are sometimes. Instead, it’s what you do with that feeling. Being aroused is a powerful form of energy, but no one taught us how to use that energy. As a tantric experience, embracing that can release some level of shame,” he says.</p>
<p>Alvarez teaches three types of yoga: hatha, vinyasa flow and yin. He intends to host power flow, which he describes as a bit more advanced. Classes currently run $15 and also feature a post-session of tantra (for $10) which dives into meditation and reflection. He also provides private instruction. As his rebranding settles, Alvarez also expects to expand classes for women and workshops to explore queer yoga spaces.</p>
<p>For those coming to his class — especially those with some reluctance or lack of assurance — Alvarez only has one piece of advice: “Have an open mind. It’s OK to feel anxious. That’s a natural feeling. We’re there to help take care of each other.”</p>
<p>Visit radical.yoga for class schedules and to purchase a session.</p>
<p>&#8230;&#8230;&#8230;&#8230;</p>
<h4>STRIKE A POSE</h4>
<p><img class="alignleft size-full wp-image-1000316069" src="https://dallasvoice.com/wp-content/uploads/2020/01/Yoga-side-bar.jpg" alt="" width="500" height="750" srcset="https://dallasvoice.com/wp-content/uploads/2020/01/Yoga-side-bar.jpg 500w, https://dallasvoice.com/wp-content/uploads/2020/01/Yoga-side-bar-200x300.jpg 200w" sizes="(max-width: 500px) 100vw, 500px" />Roberto Alvarez Jr., founder and owner of Radical Yoga, describes the different types of yoga his studio teaches.</p>
<p><strong>Vinyasa flow</strong>: “This has a New Age feel. There’s a lot of movement with breath. I see it almost as a form of dance going in and out of different poses.”</p>
<p><strong>Hatha</strong>: “This removes some of the flow found in vinyasa flow. So we may stand on the left leg and hold a pose as opposed to moving in and out of poses. It’s a very traditional form.”</p>
<p><strong>Yin</strong>: “This takes out flow completely and more so targets the connective tissues over the muscles. So when we are holding a butterfly pose, we focus on the inner thighs. We would hold for 3–5 minutes.”</p>
<p><strong>Tantra</strong>: Its own thing, this involves couples pairings, though not in a sexual way. “There’s touching, like hand-on-heart poses.”</p>
<p style="text-align: right;"><em>— Rich Lopez</em></p>
</div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://dallasvoice.com/om-naturel/&#038;t=Om%20naturel" class="social-share-link" title="Share &quot;Om naturel&quot; via Facebook" data-network-name="facebook" data-share-title="Om naturel" data-share-url="https://dallasvoice.com/om-naturel/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=Om%20naturel%20https://dallasvoice.com/om-naturel/" class="social-share-link" title="Share &quot;Om naturel&quot; via Twitter" data-network-name="twitter" data-share-title="Om naturel" data-share-url="https://dallasvoice.com/om-naturel/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://dallasvoice.com/om-naturel/&#038;title=Om%20naturel" class="social-share-link" title="Share &quot;Om naturel&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Om naturel" data-share-url="https://dallasvoice.com/om-naturel/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Om naturel&quot; via Email" data-network-name="basic_email" data-share-title="Om naturel" data-share-url="https://dallasvoice.com/om-naturel/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Om naturel&quot; via Print" data-network-name="basic_print" data-share-title="Om naturel" data-share-url="https://dallasvoice.com/om-naturel/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #35c7cb;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://dallasvoice.com/doris-miller-recognized/" rel="prev"><span class="button">Previous</span><span class="title">Doris Miller recognized</span></a> </div>
<div class="nav-link nav-link-next">
<a href="https://dallasvoice.com/fit-food-fit-for-a-queen/" rel="next"><span class="button">Next</span><span class="title">Fit food fit for a queen</span></a> </div>
</div>
</nav>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/om-naturel/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://dallasvoice.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1000316067' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
</div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_4">
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://www.facebook.com/DallasVoiceLGBT/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/DallasVoice" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://instagram.com/dallas_voice" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
</li>
<li class="et-extra-social-icon youtube">
<a href="https://www.youtube.com/channel/UCzLKquBnVnmwE8LBYSQTK3w" class="et-extra-icon et-extra-icon-background-none et-extra-icon-youtube"></a>
</li>
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<link rel='stylesheet' id='et-gf-lato-css' href='https://fonts.googleapis.com/css?family=Lato:400,100,100italic,300,300italic,400italic,700,700italic,900,900italic&#038;subset=latin' type='text/css' media='all' />
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='https://dallasvoice.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript' src='https://dallasvoice.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/dallasvoice.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/dallasvoice.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"693126c4f8","timeline_nonce":"c35136b670","blog_feed_nonce":"9f5d626067","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/dallasvoice.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/dallasvoice.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/dallasvoice.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"495a87f34f","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"ae3524464c","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"1000316067","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://dallasvoice.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=4.2.1'></script>
<script type='text/javascript' src='https://dallasvoice.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://dallasvoice.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.2.2'></script>
<script type='text/javascript' src='https://dallasvoice.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.2.1'></script>
<script type='text/javascript' src='https://dallasvoice.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>

<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:60000,repeat_impressions:'Y'});
	jQuery('.g-2').gslider({groupid:2,speed:60000,repeat_impressions:'Y'});
	jQuery('.g-3').gslider({groupid:3,speed:60000,repeat_impressions:'Y'});
	jQuery('.g-4').gslider({groupid:4,speed:60000,repeat_impressions:'Y'});
	jQuery('.g-5').gslider({groupid:5,speed:60000,repeat_impressions:'Y'});
	jQuery('.g-6').gslider({groupid:6,speed:60000,repeat_impressions:'Y'});
	jQuery('.g-7').gslider({groupid:7,speed:60000,repeat_impressions:'Y'});
	jQuery('.g-8').gslider({groupid:8,speed:60000,repeat_impressions:'Y'});
}});
</script>

</body>
</html>
