<!DOCTYPE html> <!--[if IE 6]><html id="ie6" lang="en-US"> <![endif]--> <!--[if IE 7]><html id="ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html id="ie8" lang="en-US"> <![endif]--> <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge"><script data-cfasync="false" id="ao_optimized_gfonts_config" type="text/javascript">WebFontConfig={google:{families:["Lato:400,100,100italic,300,300italic,400italic,700,700italic,900,900italic:latin"] },classes:false, events:false, timeout:1500};</script><link rel="pingback" href="https://dallasvoice.com/xmlrpc.php" /> <!--[if lt IE 9]> <script src="https://dallasvoice.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script> <![endif]--> <script>var et_site_url='https://dallasvoice.com';var et_post_id='1000311976';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script><link type="text/css" media="all" href="https://dallasvoice.com/wp-content/cache/autoptimize/css/autoptimize_568430014d95a68544a4edfa20adad7e.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://dallasvoice.com/wp-content/cache/autoptimize/css/autoptimize_e9b68fa9840698a0b48b3cdb12486605.css" rel="stylesheet" /><title>Angelica Ross to host presidential forum - Dallas Voice</title> <link rel="canonical" href="https://dallasvoice.com/angelica-ross-to-host-presidential-forum/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Angelica Ross to host presidential forum - Dallas Voice" /><meta property="og:description" content="Transgender activist and actress Angelica Ross will host the 2020 Presidential Candidate Forum on LGBTQ Issues set for Friday, Sept. 20, in Coe College’s Sinclair Auditorium in Cedar Rapids, Ia. The forum will stream live. Ross is the first transgender person to host a presidential candidate forum. The forum is presented by GLAAD, One Iowa, &hellip;" /><meta property="og:url" content="https://dallasvoice.com/angelica-ross-to-host-presidential-forum/" /><meta property="og:site_name" content="Dallas Voice" /><meta property="article:tag" content="American Horror Story 1984" /><meta property="article:tag" content="Amy Klobuchar" /><meta property="article:tag" content="Andrew Yang" /><meta property="article:tag" content="Angelica Ross" /><meta property="article:tag" content="Bernie" /><meta property="article:tag" content="Beto" /><meta property="article:tag" content="Billy Gilman" /><meta property="article:tag" content="Cory Booker" /><meta property="article:tag" content="Elizabeth Warren" /><meta property="article:tag" content="joe biden" /><meta property="article:tag" content="Joe Sestak" /><meta property="article:tag" content="julian castro" /><meta property="article:tag" content="kamala harris" /><meta property="article:tag" content="Marrianne Williamson" /><meta property="article:tag" content="Pete Buttigieg" /><meta property="article:tag" content="Pose" /><meta property="article:tag" content="Presidential forum" /><meta property="article:tag" content="Sarah Kate Ellis" /><meta property="article:tag" content="Tulsi Gabbard" /><meta property="article:section" content="Featured" /><meta property="article:published_time" content="2019-09-16T21:29:02+00:00" /><meta property="og:image" content="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header.jpg" /><meta property="og:image:secure_url" content="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header.jpg" /><meta property="og:image:width" content="948" /><meta property="og:image:height" content="517" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Transgender activist and actress Angelica Ross will host the 2020 Presidential Candidate Forum on LGBTQ Issues set for Friday, Sept. 20, in Coe College’s Sinclair Auditorium in Cedar Rapids, Ia. The forum will stream live. Ross is the first transgender person to host a presidential candidate forum. The forum is presented by GLAAD, One Iowa, [&hellip;]" /><meta name="twitter:title" content="Angelica Ross to host presidential forum - Dallas Voice" /><meta name="twitter:image" content="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header.jpg" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://dallasvoice.com/#website","url":"https://dallasvoice.com/","name":"Dallas Voice","potentialAction":{"@type":"SearchAction","target":"https://dallasvoice.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://dallasvoice.com/angelica-ross-to-host-presidential-forum/#primaryimage","url":"https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header.jpg","width":948,"height":517},{"@type":"WebPage","@id":"https://dallasvoice.com/angelica-ross-to-host-presidential-forum/#webpage","url":"https://dallasvoice.com/angelica-ross-to-host-presidential-forum/","inLanguage":"en-US","name":"Angelica Ross to host presidential forum - Dallas Voice","isPartOf":{"@id":"https://dallasvoice.com/#website"},"primaryImageOfPage":{"@id":"https://dallasvoice.com/angelica-ross-to-host-presidential-forum/#primaryimage"},"datePublished":"2019-09-16T21:29:02+00:00","dateModified":"2019-09-16T21:29:02+00:00","author":{"@id":"https://dallasvoice.com/#/schema/person/0c5c969b5ef6fe4b0fd0ac7e45ec24a0"}},{"@type":["Person"],"@id":"https://dallasvoice.com/#/schema/person/0c5c969b5ef6fe4b0fd0ac7e45ec24a0","name":"Tammye","image":{"@type":"ImageObject","@id":"https://dallasvoice.com/#authorlogo","url":"https://secure.gravatar.com/avatar/6d8478a832ba8aa3e7dd744679c7a4a4?s=96&d=mm&r=g","caption":"Tammye"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//s.w.org' /><link href='https://cdn.shortpixel.ai' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Dallas Voice &raquo; Feed" href="https://dallasvoice.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Dallas Voice &raquo; Comments Feed" href="https://dallasvoice.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Dallas Voice &raquo; Angelica Ross to host presidential forum Comments Feed" href="https://dallasvoice.com/angelica-ross-to-host-presidential-forum/feed/" /><meta content="Dallas Voice v.1.0.0" name="generator" /><link rel='stylesheet' id='dashicons-css' href='https://dallasvoice.com/wp-includes/css/dashicons.min.css?ver=53db96abec781d2efce1fba220f6a733' type='text/css' media='all' /> <script type='text/javascript' src='https://dallasvoice.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript'>/* <![CDATA[ */
var aamLocal = {"nonce":"ddaef92deb","ajaxurl":"https:\/\/dallasvoice.com\/wp-admin\/admin-ajax.php"};
/* ]]> */</script> <link rel='https://api.w.org/' href='https://dallasvoice.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dallasvoice.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dallasvoice.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://dallasvoice.com/?p=1000311976' /><link rel="alternate" type="application/json+oembed" href="https://dallasvoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdallasvoice.com%2Fangelica-ross-to-host-presidential-forum%2F" /><link rel="alternate" type="text/xml+oembed" href="https://dallasvoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdallasvoice.com%2Fangelica-ross-to-host-presidential-forum%2F&#038;format=xml" />    <script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//dallasvoice.com/?wordfence_lh=1&hid=49055C464077353BA60B93C14F04052C');</script><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-60733171-1"></script>   <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-73606430-12', 'auto');
  ga('send', 'pageview');</script> <link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://dallasvoice.com/wp-content/cache/et/global/et-extra-customizer-global-15684408714839.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><link rel="stylesheet" id="et-core-unified-cached-inline-styles" href="https://dallasvoice.com/wp-content/cache/et/1000311976/et-core-unified-15686693556155.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader" type="text/javascript">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-1000311976 single-format-standard et_bloom et_extra et_non_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css"><div id="page-container" class="page-container"> <header class="header left-right"> <div id="top-header" style=""><div class="container"> <div id="et-secondary-nav" class=""><ul id="et-secondary-menu" class="nav"><li id="menu-item-256438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256438"><a href="/advertising">Advertise With Us</a></li><li id="menu-item-256439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256439"><a href="/marketplace">Marketplace</a><ul class="sub-menu"><li id="menu-item-256440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256440"><a href="/marketplace">View This Week&#8217;s PDF</a></li><li id="menu-item-256441" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256441"><a href="https://dallasvoice.com/wp-content/uploads/2017/10/MarketPlace-Rate-Card.pdf">Marketplace Media Kit</a></li></ul></li><li id="menu-item-256442" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256442"><a href="/outnorthtexas">OUT North Texas</a><ul class="sub-menu"><li id="menu-item-256443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256443"><a href="https://dallasvoice.com/wp-content/uploads/2019/01/OUT-NT-2019.pdf">Read the Magazine</a></li><li id="menu-item-256444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256444"><a href="https://directory.outntx.com/">Business Directory</a></li><li id="menu-item-256445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256445"><a href="https://dallasvoice.com/outnorthtexas/media-kit/">OUT Media Kit</a></li></ul></li><li id="menu-item-256446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256446"><a href="/media-kit">Digital Services</a></li><li id="menu-item-256447" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256447"><a href="/contact">Contact Us</a></li></ul></div> <div id="et-info"> <ul class="et-extra-social-icons" style=""><li class="et-extra-social-icon facebook"> <a href="https://www.facebook.com/DallasVoiceLGBT/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a></li><li class="et-extra-social-icon twitter"> <a href="https://twitter.com/DallasVoice" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a></li><li class="et-extra-social-icon instagram"> <a href="https://instagram.com/dallas_voice" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a></li><li class="et-extra-social-icon youtube"> <a href="https://www.youtube.com/channel/UCzLKquBnVnmwE8LBYSQTK3w" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-youtube"></a></li></ul> <div class="et-top-search" style=""><form role="search" class="et-search-form" method="get" action="https://dallasvoice.com/"> <input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" /> <button class="et-search-submit"></button></form></div> </div></div></div> <div id="main-header-wrapper"><div id="main-header" data-fixed-height="80"><div class="container">   <a class="logo" href="https://dallasvoice.com/" data-fixed-height="51"> <noscript><img src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2018/08/aaabfd4f-dallasvoice_website_logo_cyan.png" alt="Dallas Voice" id="logo" /></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2018/08/aaabfd4f-dallasvoice_website_logo_cyan.png" alt="Dallas Voice" id="logo" /> </a> <div id="et-navigation" class=""><ul id="et-menu" class="nav"><li id="menu-item-256449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256449"><a href="/category/news">News</a><ul class="sub-menu"><li id="menu-item-256450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256450"><a href="/category/news/texas">Local News</a></li><li id="menu-item-256451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256451"><a href="/category/news/national">National News</a></li><li id="menu-item-256452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256452"><a href="/category/featured">Featured</a><ul class="sub-menu"><li id="menu-item-256453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256453"><a href="/lambda">Lambda Weekly</a></li><li id="menu-item-1000292637" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1000292637"><a href="https://dallasvoice.com/category/editorial-cartoon/">Editorial Cartoon</a></li><li id="menu-item-1000292638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1000292638"><a href="https://dallasvoice.com/category/crossword/">Crossword Puzzle</a></li></ul></li></ul></li><li id="menu-item-256454" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-256454"><a href="https://dallasvoice.com/category/lifestyle/">Life+Style</a><ul class="sub-menu"><li id="menu-item-256455" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256455"><a href="https://dallasvoice.com/category/profile/">Profile</a></li><li id="menu-item-256456" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256456"><a href="https://dallasvoice.com/category/stage/">Stage</a></li><li id="menu-item-256457" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256457"><a href="https://dallasvoice.com/category/screen/">Screen</a></li><li id="menu-item-256458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256458"><a href="https://dallasvoice.com/category/dining/">Dining</a></li><li id="menu-item-256466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256466"><a href="https://dallasvoice.com/category/travel/">Travel</a></li><li id="menu-item-256467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256467"><a href="https://dallasvoice.com/category/community/">Community</a></li><li id="menu-item-256468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256468"><a href="https://dallasvoice.com/category/tube/">Tube</a></li><li id="menu-item-256469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256469"><a href="https://dallasvoice.com/category/concert-lifestyle/">Concert</a></li><li id="menu-item-256470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256470"><a href="https://dallasvoice.com/category/music/">Music</a></li><li id="menu-item-256471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256471"><a href="https://dallasvoice.com/category/books/">Books</a></li><li id="menu-item-256472" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256472"><a href="https://dallasvoice.com/category/fashion/">Fashion</a></li><li id="menu-item-256473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256473"><a href="https://dallasvoice.com/category/auto/">Auto</a></li><li id="menu-item-256474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256474"><a href="https://dallasvoice.com/category/scoop-lifestyle/">Scoop</a></li><li id="menu-item-256475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256475"><a href="https://dallasvoice.com/category/sports/">Sports</a></li><li id="menu-item-256476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256476"><a href="https://dallasvoice.com/category/sketches/">Sketches</a></li><li id="menu-item-256477" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256477"><a href="https://dallasvoice.com/category/pride/">Pride</a></li><li id="menu-item-256478" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256478"><a href="https://dallasvoice.com/category/advice/">Advice</a></li><li id="menu-item-256479" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256479"><a href="https://dallasvoice.com/category/plan-your-week/best-bets/">Best Bets</a></li></ul></li><li id="menu-item-256480" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-256480"><a href="/category/instantea">InstanTEA</a><ul class="sub-menu"><li id="menu-item-256481" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-256481"><a href="https://dallasvoice.com/category/instantea/news-instant-tea/">InstanTEA News</a></li><li id="menu-item-256482" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256482"><a href="https://dallasvoice.com/category/instantea/lifestyle-instant-tea/">InstanTEA Life+Style</a></li><li id="menu-item-256483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256483"><a href="https://dallasvoice.com/category/instantea/community-voices-instant-tea/">CommUNITY Voices</a></li></ul></li><li id="menu-item-256484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256484"><a href="/category/special-editions">Special Sections</a></li><li id="menu-item-256485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256485"><a href="/plan-your-week">Plan Your Week</a></li></ul><div id="et-mobile-navigation"> <span class="show-menu"><div class="show-menu-button"> <span></span> <span></span> <span></span></div><p>Select Page</p> </span><nav></nav></div> </div></div></div></div></header><div id="main-content"><div class="post-ads"><div class=container><div class="post-ad-1"><div class="g g-4"><div class="g-dyn a-299 c-1"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'Black Tie Dinner/Leo', 'value': 1.00,  'non_interaction': true});" href="https://blacktie.org/tables" target="_blank"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Black Tie Dinner/Leo', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/BTD-_ROS_TableCaptain.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Black Tie Dinner/Leo', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/BTD-_ROS_TableCaptain.jpg" /></a></div><div class="g-dyn a-308 c-2"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'AEG (Cirque Musica)/E', 'value': 1.00,  'non_interaction': true});" href="https://www.cirquemusica.com/holiday-wishes" target="_blank"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'AEG (Cirque Musica)/E', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/10094006/1.-CIrque-Musica.jpeg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'AEG (Cirque Musica)/E', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/10094006/1.-CIrque-Musica.jpeg" /></a></div></div></div><div class="post-ad-2"></div></div></div><div class="container"><div id="content-area" class="clearfix"></div><div class="container"><div id="content-area" class="clearfix"><div class="et_pb_extra_column_main"><article id="post-1000311976" class="module single-post-module post-1000311976 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news-instant-tea category-instantea tag-american-horror-story-1984 tag-amy-klobuchar tag-andrew-yang tag-angelica-ross tag-bernie tag-beto tag-billy-gilman tag-cory-booker tag-elizabeth-warren tag-joe-biden tag-joe-sestak tag-julian-castro tag-kamala-harris tag-marrianne-williamson tag-pete-buttigieg tag-pose tag-presidential-forum tag-sarah-kate-ellis tag-tulsi-gabbard et-doesnt-have-featured_image et-has-post-format-content et_post_format-et-post-format-standard"><div class="post-header"><h1 class="entry-title">Angelica Ross to host presidential forum</h1><div class="post-meta vcard"><p><span class="updated">Sep 16, 2019</span> | <a class="comments-link" href="https://dallasvoice.com/angelica-ross-to-host-presidential-forum/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p></div></div><div class="post-wrap"><div class="post-content entry-content"><div id="attachment_1000311988" style="width: 958px" class="wp-caption aligncenter"><noscript><img aria-describedby="caption-attachment-1000311988" class="size-full wp-image-1000311988" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header.jpg" alt="" width="948" height="517" srcset="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header.jpg 948w, https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header-300x164.jpg 300w, https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header-768x419.jpg 768w, https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header-610x333.jpg 610w" sizes="(max-width: 948px) 100vw, 948px" /></noscript><img aria-describedby="caption-attachment-1000311988" class="lazyload size-full wp-image-1000311988" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20948%20517%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header.jpg" alt="" width="948" height="517" data-srcset="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header.jpg 948w, https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header-300x164.jpg 300w, https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header-768x419.jpg 768w, https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16162416/AR-header-610x333.jpg 610w" data-sizes="(max-width: 948px) 100vw, 948px" /><p id="caption-attachment-1000311988" class="wp-caption-text"><em>Angelican Ross as Candy Ferocity in Episode 4, Season 2 of </em>Pose<em>.</em></p></div><p>Transgender activist and actress Angelica Ross will host the 2020 Presidential Candidate Forum on LGBTQ Issues set for Friday, Sept. 20, in Coe College’s Sinclair Auditorium in Cedar Rapids, Ia. The forum will stream live.</p><p>Ross is the first transgender person to host a presidential candidate forum.</p><p>The forum is presented by GLAAD, One Iowa, The Gazette and The Advocate, and Zach Stafford, editor in chief of The Advocate, confirmed Ross’ participation today (Monday, Sept. 16). Candidates confirmed to be participating so far are Joe Biden, Cory Booker, Pete Buttigieg, Julián Castro, Tulsi Gabbard, Kamala Harris, Amy Klobuchar, Joe Sestak, Elizabeth Warren and Marianne Williamson, according to <a href="https://deadline.com/2019/09/angelica-ross-pose-american-horror-story-presidential-candidate-forum-lgbtq-issues-glaad-1202735593/">Deadline.com.</a> The site also reports that country singer and season 11 <em>The Voice</em> contestant Bill Gilman will sing The National Anthem to open the forum.</p><p>GLAAD has also invited Beto O&#8217;Rourke, Bernie Sanders and Andrew Yang to participate.</p><p>Ross and GLAAD President and CEO Sarah Kate Ellis will discuss with the candidates their plans for improving acceptance of the LGBT community if elected President in 2020.</p><p>Ross, 39, began her transition at 19 after a brief stint in the U.S. Navy. A self-taught computer coder, she is the founder and CEO of TransTech Social Enterprises, a firm that helps employ transgender people in the tech industry.</p><p>Ross was a featured speaker at the 2015 White House LGBTQ Tech and Innovation Summit, and in 2016 began acting in <em>Her Story</em>, a web series about trans women in Los Angeles that was nominated for an Emmy Award for Outstanding Short Form Comedy or Drama.</p><p>Ross came to national prominence with her portrayal of Candy Ferocity in seasons 1 and 2 of <a href="https://www.fxnetworks.com/shows/pose"><em>Pose</em></a> and earlier this year announced she was leaving that series to portray Nurse Rita in <a href="https://www.fxnetworks.com/shows/american-horror-story"><em>American Horror Story: 1984</em></a>, making her the first transgender actor to appear as a series regular in the <em>American Horror Story</em> franchise.</p></div></div><div class="post-footer"><div class="social-icons ed-social-share-icons"><p class="share-title">Share:</p> <a href="https://www.facebook.com/sharer.php?u=https://dallasvoice.com/angelica-ross-to-host-presidential-forum/&#038;t=Angelica%20Ross%20to%20host%20presidential%20forum" class="social-share-link" title="Share &quot;Angelica Ross to host presidential forum&quot; via Facebook" data-network-name="facebook" data-share-title="Angelica Ross to host presidential forum" data-share-url="https://dallasvoice.com/angelica-ross-to-host-presidential-forum/"> <span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span> </a><a href="https://twitter.com/intent/tweet?text=Angelica%20Ross%20to%20host%20presidential%20forum%20https://dallasvoice.com/angelica-ross-to-host-presidential-forum/" class="social-share-link" title="Share &quot;Angelica Ross to host presidential forum&quot; via Twitter" data-network-name="twitter" data-share-title="Angelica Ross to host presidential forum" data-share-url="https://dallasvoice.com/angelica-ross-to-host-presidential-forum/"> <span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span> </a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://dallasvoice.com/angelica-ross-to-host-presidential-forum/&#038;title=Angelica%20Ross%20to%20host%20presidential%20forum" class="social-share-link" title="Share &quot;Angelica Ross to host presidential forum&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Angelica Ross to host presidential forum" data-share-url="https://dallasvoice.com/angelica-ross-to-host-presidential-forum/"> <span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span> </a><a href="#" class="social-share-link" title="Share &quot;Angelica Ross to host presidential forum&quot; via Email" data-network-name="basic_email" data-share-title="Angelica Ross to host presidential forum" data-share-url="https://dallasvoice.com/angelica-ross-to-host-presidential-forum/"> <span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span> </a><a href="#" class="social-share-link" title="Share &quot;Angelica Ross to host presidential forum&quot; via Print" data-network-name="basic_print" data-share-title="Angelica Ross to host presidential forum" data-share-url="https://dallasvoice.com/angelica-ross-to-host-presidential-forum/"> <span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span> </a></div></div></article><nav class="post-nav"><div class="nav-links clearfix"><div class="nav-link nav-link-prev"> <a href="https://dallasvoice.com/new-holocaust-and-human-rights-museum-includes-lgbt-exhibits/" rel="prev"><span class="button">Previous</span><span class="title">New Holocaust and Human Rights Museum includes LGBT exhibits</span></a></div><div class="nav-link nav-link-next"></div></div></nav> <section id="comment-wrap"><div id="comments" class="nocomments"> </div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/angelica-ross-to-host-presidential-forum/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://dallasvoice.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1000311976' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></section></div><div class="et_pb_extra_column_sidebar"><div id="custom_html-2" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"></h4><div class="textwidget custom-html-widget"><div class="g g-5"><div class="g-dyn a-293 c-1"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'PRISM LifeWalk/Leo', 'value': 1.00,  'non_interaction': true});" href="https://www.lifewalk.org/event/lifewalk/" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'PRISM LifeWalk/Leo', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/06/LW_Digital_Ad_300x600_a-01.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'PRISM LifeWalk/Leo', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/06/LW_Digital_Ad_300x600_a-01.jpg" /></a></div><div class="g-dyn a-150 c-2"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'Southwest Kia/G', 'value': 1.00,  'non_interaction': true});" href="https://www.southwestkia.com" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Southwest Kia/G', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/06/Southwest-Kia.gif" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Southwest Kia/G', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/06/Southwest-Kia.gif" /></a></div></div></div></div> <div id="custom_html-3" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"></h4><div class="textwidget custom-html-widget"><div class="g g-5"><div class="g-dyn a-293 c-1"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'PRISM LifeWalk/Leo', 'value': 1.00,  'non_interaction': true});" href="https://www.lifewalk.org/event/lifewalk/" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'PRISM LifeWalk/Leo', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/06/LW_Digital_Ad_300x600_a-01.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'PRISM LifeWalk/Leo', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/06/LW_Digital_Ad_300x600_a-01.jpg" /></a></div><div class="g-dyn a-150 c-2"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'Southwest Kia/G', 'value': 1.00,  'non_interaction': true});" href="https://www.southwestkia.com" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Southwest Kia/G', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/06/Southwest-Kia.gif" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Southwest Kia/G', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/06/Southwest-Kia.gif" /></a></div></div></div></div> <div id="custom_html-4" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"></h4><div class="textwidget custom-html-widget"><div class="g g-6"><div class="g-dyn a-312 c-1"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 1.00,  'non_interaction': true});" href="https://www.mydso.com/buy/tickets/chicago-the-musical" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></a></div><div class="g-dyn a-298 c-2"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 1.00,  'non_interaction': true});" href="https://www.kanarys.com/" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></a></div></div></div></div> <div id="custom_html-5" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"></h4><div class="textwidget custom-html-widget"><div class="g g-6"><div class="g-dyn a-312 c-1"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 1.00,  'non_interaction': true});" href="https://www.mydso.com/buy/tickets/chicago-the-musical" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></a></div><div class="g-dyn a-298 c-2"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 1.00,  'non_interaction': true});" href="https://www.kanarys.com/" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></a></div></div></div></div> <div id="custom_html-6" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"></h4><div class="textwidget custom-html-widget"><div class="g g-6"><div class="g-dyn a-312 c-1"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 1.00,  'non_interaction': true});" href="https://www.mydso.com/buy/tickets/chicago-the-musical" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></a></div><div class="g-dyn a-298 c-2"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 1.00,  'non_interaction': true});" href="https://www.kanarys.com/" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></a></div></div></div></div> <div id="custom_html-7" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"></h4><div class="textwidget custom-html-widget"><div class="g g-6"><div class="g-dyn a-312 c-1"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 1.00,  'non_interaction': true});" href="https://www.mydso.com/buy/tickets/chicago-the-musical" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></a></div><div class="g-dyn a-298 c-2"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 1.00,  'non_interaction': true});" href="https://www.kanarys.com/" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></a></div></div></div></div> <div id="custom_html-8" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"></h4><div class="textwidget custom-html-widget"><div class="g g-6"><div class="g-dyn a-312 c-1"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 1.00,  'non_interaction': true});" href="https://www.mydso.com/buy/tickets/chicago-the-musical" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'DSO/e Chicago', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/09/16112404/DSO-Chicago.jpg" /></a></div><div class="g-dyn a-298 c-2"><a onClick="gtag('event', 'click', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 1.00,  'non_interaction': true});" href="https://www.kanarys.com/" target="_blank" rel="noopener noreferrer"><noscript><img onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></noscript><img class="lazyload" onload="gtag('event', 'impression', {'event_category': 'Adverts', 'event_label': 'Kanary\&#039;s/E', 'value': 2.00, 'non_interaction': true});" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://sfo2.digitaloceanspaces.com/dv-media/wp-content/uploads/2019/07/kanarys.jpg" /></a></div></div></div></div> </div></div> </div> </div> <footer id="footer" class="footer_columns_4"><div id="footer-bottom"><div class="container"> <p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p> <div id="footer-nav"><ul class="et-extra-social-icons" style=""><li class="et-extra-social-icon facebook"> <a href="https://www.facebook.com/DallasVoiceLGBT/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a></li><li class="et-extra-social-icon twitter"> <a href="https://twitter.com/DallasVoice" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a></li><li class="et-extra-social-icon instagram"> <a href="https://instagram.com/dallas_voice" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a></li><li class="et-extra-social-icon youtube"> <a href="https://www.youtube.com/channel/UCzLKquBnVnmwE8LBYSQTK3w" class="et-extra-icon et-extra-icon-background-none et-extra-icon-youtube"></a></li></ul></div> </div></div></footer></div>  <noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://dallasvoice.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/dallasvoice.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/dallasvoice.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"163caffe0e","timeline_nonce":"73d73d89ad","blog_feed_nonce":"af984924c9","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/dallasvoice.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/dallasvoice.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/dallasvoice.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"8c8ecc65b6","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"bd61261a8c","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"1000311976","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */</script>   <script type="text/javascript" defer src="https://dallasvoice.com/wp-content/cache/autoptimize/js/autoptimize_250961251cae69da11b77be5696a1ade.js"></script></body></html>